1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Matt Monaco <cx monaco matt>
6 _commit=8f44dca45d87bc1f8da65428172668c5e6154179
8 pkgdesc="Symas Lightning Memory-Mapped Database"
10 url="https://symas.com/lmdb"
11 license=('custom:OpenLDAP')
14 options=('!emptydirs')
15 source=("git+https://git.openldap.org/openldap/openldap.git#commit=$_commit"
18 '0349d4b08a1f93fe338d8f8e3e5a83e24211a46f999fe529bc1ac49c8c4975559d95a548c203d9427e3f82d62e934ba3cd1be6f734f9b9405b2a26477be4ed33')
21 sed -e "s|@PKGVER@|$pkgver|" -i lmdb.pc
25 cd openldap/libraries/liblmdb
26 make CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" LDFLAGS="$LDFLAGS" prefix=/usr
30 cd openldap/libraries/liblmdb
35 cd openldap/libraries/liblmdb
36 install -dm755 "$pkgdir"/usr/{bin,lib,include,man/man1,share}
37 make DESTDIR="$pkgdir" prefix=/usr install
39 mv "$pkgdir"/usr/man "$pkgdir"/usr/share/man
41 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
42 install -Dm644 "$srcdir"/lmdb.pc -t "$pkgdir"/usr/lib/pkgconfig/