db-move: moved gnome-terminal from [staging] to [testing] (x86_64)
[arch-packages.git] / m17n-lib / trunk / PKGBUILD
blobdcc8c17de0fc0d3b17d85c1c52a6d5b209938449
1 # Maintainer: Gaetan Bisson <bisson@archlinux.org>
2 # Contributor: Camille Moncelier <pix@devlife.org>
4 pkgname=m17n-lib
5 pkgver=1.8.0
6 pkgrel=13
7 pkgdesc='Multilingual text processing library (runtimes)'
8 url='https://www.nongnu.org/m17n/'
9 arch=('x86_64')
10 license=('GPL')
11 depends=('libxft' 'm17n-db' 'fribidi' 'libthai' 'libxml2' 'gd' 'libotf')
12 makedepends=('anthy' 'ispell')
13 optdepends=('anthy: to use the anthy input method'
14             'ispell: to use the ispell input method')
15 options=('!makeflags' '!emptydirs')
16 validpgpkeys=('D68584F9B40A6502FD7C53015F592A4029890630')
17 source=("https://download.savannah.gnu.org/releases/m17n/${pkgname}-${pkgver}.tar.gz")
18 sha256sums=('78bacae7451822dfff62482ce4f9433c5ae82846e4c64b590541e29e800fe64a')
20 prepare() {
21   cd ${pkgname}-${pkgver}
22   sed -i 's/freetype-config/pkg-config freetype2/' configure
25 build() {
26   cd ${pkgname}-${pkgver}
27   ./configure --prefix=/usr
28   make
31 package() {
32   cd ${pkgname}-${pkgver}
33   make DESTDIR="${pkgdir}" install