db-move: moved gdm from [testing] to [extra] (x86_64)
[arch-packages.git] / empathy / repos / extra-x86_64 / PKGBUILD
blob6d02c9812e57b74a480e3887e0f4c8b858f82f21
1 # $Id$
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=empathy
5 pkgver=3.25.90+34+g78f4d4fda
6 pkgrel=3
7 pkgdesc="A GNOME instant messaging client using the Telepathy framework"
8 url="https://wiki.gnome.org/Apps/Empathy"
9 arch=(x86_64)
10 license=(GPL2)
11 depends=(clutter-gst clutter-gtk folks gcr iso-codes libcanberra libpulse webkit2gtk
12          telepathy-farstream telepathy-glib telepathy-logger telepathy-mission-control geoclue2
13          geocode-glib cheese libchamplain libgudev)
14 makedepends=(intltool itstool docbook-xsl python gnome-common git)
15 optdepends=('telepathy-gabble: XMPP/Jabber support'
16             'telepathy-idle: IRC support'
17             'telepathy-salut: Link-local XMPP support'
18             'telepathy-haze: libpurple support')
19 _commit=78f4d4fdadd7da67e063c2905649f6a6015ef8f9  # master
20 source=("git+https://git.gnome.org/browse/empathy#commit=$_commit"
21         "git+https://git.gnome.org/browse/telepathy-account-widgets"
22         enchant-2.patch)
23 sha256sums=('SKIP'
24             'SKIP'
25             'f177f0dfc242018dd52e312637f513fd08f64aa991b45930cc3ea9a2576f795e')
27 pkgver() {
28   cd $pkgname
29   git describe --tags | sed 's/^EMPATHY_//;s/_/./g;s/-/+/g'
32 prepare() {
33   cd $pkgname
35   git submodule init
36   git config --local submodule.telepathy-account-widgets.url "$srcdir/telepathy-account-widgets"
37   git submodule update
39   patch -Np1 -i ../enchant-2.patch
41   NOCONFIGURE=1 ./autogen.sh
44 build() {
45   cd $pkgname
46   export LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
47   ./configure --prefix=/usr \
48       --sysconfdir=/etc  \
49       --libexecdir=/usr/lib/empathy \
50       --disable-static \
51       --disable-Werror
52   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
53   make
56 package() {
57   cd $pkgname
58   make DESTDIR="$pkgdir" install