1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
5 pkgname=(gdk-pixbuf2 gdk-pixbuf2-docs)
8 pkgdesc="An image loading library"
9 url="https://wiki.gnome.org/Projects/GdkPixbuf"
12 depends=(glib2 libpng libtiff libjpeg shared-mime-info)
13 makedepends=(gobject-introspection git meson gi-docgen python-docutils)
15 "libwmf: Load .wmf and .apm"
16 "libopenraw: Load .dng, .cr2, .crw, .nef, .orf, .pef, .arw, .erf, .mrw, and .raf"
18 "libheif: Load .heif, .heic, and .avif"
20 "librsvg: Load .svg, .svgz, and .svg.gz"
21 "webp-pixbuf-loader: Load .webp"
23 _commit=9ac257eb38f772fec4253e8051743029e75a2acd # tags/2.42.10^0
25 "git+https://gitlab.gnome.org/GNOME/gdk-pixbuf.git#commit=$_commit"
26 gdk-pixbuf-query-loaders.hook
29 '9fb71d95e6a212779eb0f88dde5a3cee0df7f4d9183f8f9ce286f8cdc14428f0')
33 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
41 arch-meson gdk-pixbuf build \
42 -D builtin_loaders=all \
44 -D installed_tests=false
45 meson compile -C build
49 meson test -C build --print-errorlogs
52 package_gdk-pixbuf2() {
53 provides=(libgdk_pixbuf-2.0.so)
54 install=gdk-pixbuf2.install
56 meson install -C build --destdir "$pkgdir"
58 mkdir -p doc/usr/share
59 mv {"$pkgdir",doc}/usr/share/doc
61 install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
64 package_gdk-pixbuf2-docs() {
65 pkgdesc+=" (documentation)"
71 # vim:set sw=2 sts=-1 et: