upgpkg: ocaml-integers 0.5.0-1
[arch-packages.git] / flatpak / trunk / PKGBUILD
blobe3c3b2bda2f3bb9f1a6e12dda34ab7a92dde4804
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
5 pkgname=flatpak
6 pkgver=1.12.2
7 pkgrel=1
8 pkgdesc="Linux application sandboxing and distribution framework (formerly xdg-app)"
9 url="https://flatpak.org"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(dbus glib2 libsoup polkit libxau ostree json-glib libseccomp libarchive
13          python bubblewrap appstream-glib xdg-dbus-proxy systemd)
14 makedepends=(intltool gobject-introspection gtk-doc git docbook-xsl xmlto)
15 checkdepends=(valgrind socat)
16 _commit=96aafda476c2634941dfcd68a65fe13f582eefcb  # tags/1.12.2^0
17 source=("git+https://github.com/flatpak/flatpak#commit=$_commit"
18         git+https://gitlab.gnome.org/GNOME/libglnx.git
19         git+https://github.com/projectatomic/bubblewrap
20         git+https://github.com/flatpak/xdg-dbus-proxy
21         git+https://gitlab.gnome.org/alexl/variant-schema-compiler.git
22         https://dl.flathub.org/repo/flathub.flatpakrepo
23         flatpak-bindir.sh)
24 sha256sums=('SKIP'
25             'SKIP'
26             'SKIP'
27             'SKIP'
28             'SKIP'
29             '3371dd250e61d9e1633630073fefda153cd4426f72f4afa0c3373ae2e8fea03a'
30             '1824cb4eb1cc88702cb2b9f1c55b6dfdf20fca5eab83f6e8e532099281328745')
32 prepare() {
33   cd $pkgname
35   git submodule init
36   git submodule set-url bubblewrap "$srcdir/bubblewrap"
37   git submodule set-url libglnx "$srcdir/libglnx"
38   git submodule set-url dbus-proxy "$srcdir/xdg-dbus-proxy"
39   git submodule set-url variant-schema-compiler "$srcdir/variant-schema-compiler"
40   git submodule update
42   # https://github.com/flatpak/flatpak/issues/267
43   sed -i '/locale\/C\./d' tests/make-test-runtime.sh
45   NOCONFIGURE=1 ./autogen.sh
48 pkgver() {
49   cd $pkgname
50   git describe --tags | sed 's/-/+/g'
53 build() {
54   cd $pkgname
56   ./configure \
57     --prefix=/usr \
58     --sysconfdir=/etc \
59     --localstatedir=/var \
60     --sbindir=/usr/bin \
61     --libexecdir=/usr/lib \
62     --disable-static \
63     --enable-gtk-doc \
64     --with-system-bubblewrap \
65     --with-system-dbus-proxy \
66     --with-dbus-config-dir=/usr/share/dbus-1/system.d
68   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
70   make
73 check() {
74   cd $pkgname
75   make -k check
78 package() {
79   depends+=(xdg-desktop-portal)
81   make -C $pkgname DESTDIR="$pkgdir" install
83   install -Dt "$pkgdir/etc/profile.d" -m644 flatpak-bindir.sh
84   install -Dt "$pkgdir/etc/flatpak/remotes.d" flathub.flatpakrepo
86   # Fixup mode to match polkit
87   install -d -o root -g 102 -m 750 "$pkgdir/usr/share/polkit-1/rules.d"