upgpkg: ocaml-integers 0.5.0-1
[arch-packages.git] / gnome-chess / trunk / PKGBUILD
blob08078c608553bb1d6fc4a30465fba8700ce7c281
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-chess
5 pkgver=41.1
6 pkgrel=1
7 pkgdesc="Play the classic two-player boardgame of chess"
8 url="https://wiki.gnome.org/Apps/Chess"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk4 librsvg)
12 makedepends=(gobject-introspection yelp-tools vala git meson) 
13 optdepends=('gnuchess: Play against computer')
14 groups=(gnome-extra)
15 _commit=1e5cf800528877aa9571d53503ec361f812b3705  # tags/41.1^0
16 source=("git+https://gitlab.gnome.org/GNOME/gnome-chess.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"