upgpkg: ocaml-integers 0.5.0-1
[arch-packages.git] / kitemmodels / repos / testing-x86_64 / PKGBUILD
blob0fd4b20de6545b4daa42736b10e74fc8f6068845
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kitemmodels
6 pkgver=5.88.0
7 pkgrel=3
8 pkgdesc='Models for Qt Model/View system'
9 arch=(x86_64)
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(qt5-base)
13 makedepends=(extra-cmake-modules python-pyqt5 clang doxygen qt5-tools qt5-doc sip4 qt5-declarative)
14 optdepends=('python-pyqt5: for the Python bindings' 'qt5-declarative: QML bindings')
15 groups=(kf5)
16 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('60f4e112f6862f7e0536e625ce53ec67c77c873d9802ef92f485b5d752b383fe'
18             'SKIP')
19 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF \
24     -DBUILD_QCH=ON
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build