1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
8 pkgdesc="SVG rendering library"
9 url="https://wiki.gnome.org/Projects/LibRsvg"
12 depends=(gdk-pixbuf2 pango)
13 makedepends=(gobject-introspection vala gtk-doc git rust)
14 provides=(librsvg-${pkgver%%.*}.so)
15 _commit=2f6f58ef7edda386badf24d2beac153f0195723a # tags/2.52.4^0
16 source=("git+https://gitlab.gnome.org/GNOME/librsvg.git#commit=$_commit")
21 git describe --tags | sed 's/-/+/g'
26 NOCONFIGURE=1 ./autogen.sh
30 export CARGO_PROFILE_RELEASE_LTO=true CARGO_PROFILE_RELEASE_CODEGEN_UNITS=1
34 ./configure --prefix=/usr --disable-static --enable-vala \
36 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' libtool
42 # Test suite is very dependent on the versions of
43 # Cairo, Pango, FreeType and HarfBuzz
49 make DESTDIR="$pkgdir" install