upgpkg: ocaml-integers 0.5.0-1
[arch-packages.git] / zimg / trunk / PKGBUILD
blob7aefb694531b497b0f957d2dcf1bb01e36c7de1f
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
4 pkgname=zimg
5 pkgver=3.0.3
6 pkgrel=1
7 pkgdesc='Scaling, colorspace conversion, and dithering library'
8 arch=(x86_64)
9 url=https://github.com/sekrit-twc/zimg
10 license=(custom:WTFPL)
11 depends=(
12   gcc-libs
13   glibc
15 makedepends=(git)
16 provides=(libzimg.so)
17 options=(!emptydirs)
18 _tag=1658ce429cf944e88868a88d8aef4683425d4e78
19 source=(git+https://github.com/sekrit-twc/zimg.git#tag=${_tag})
20 sha256sums=(SKIP)
22 prepare() {
23   cd zimg
24   ./autogen.sh
27 pkgver() {
28   cd zimg
29   git describe --tags | sed 's/^release-//'
32 build() {
33   cd zimg
34   ./configure \
35     --prefix=/usr \
36     --enable-x86simd \
37     --disable-static
38   make
41 package(){
42   make DESTDIR="${pkgdir}" -C zimg install
43   install -Dm 644 zimg/COPYING -t "${pkgdir}"/usr/share/licenses/zimg/
46 # vim: ts=2 sw=2 et: