upgpkg: ocaml-topkg 1.0.5-2
[arch-packages.git] / devhelp / trunk / PKGBUILD
blob3dad10354b2baf884fe6081e27a9ab466d2c2379
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Link Dupont <link@subpop.net>
5 pkgbase=devhelp
6 pkgname=(devhelp devhelp-docs)
7 pkgver=43.0
8 pkgrel=1
9 pkgdesc="API documentation browser for GNOME"
10 url="https://wiki.gnome.org/Apps/Devhelp"
11 arch=(x86_64)
12 license=(GPL)
13 depends=(webkit2gtk-4.1)
14 makedepends=(git appstream-glib gobject-introspection meson yelp-tools
15              gi-docgen)
16 _commit=f4e68f3f0134becbdd737eaac85caaa0a8e43a66  # tags/43.0^0
17 source=("git+https://gitlab.gnome.org/GNOME/devhelp.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd devhelp
22   git describe --tags | sed 's/\.alpha/alpha/;s/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd devhelp
29 build() {
30   local meson_options=(
31     -D gtk_doc=true
32     -D plugin_emacs=true
33     -D plugin_gedit=true
34     -D plugin_vim=true
35   )
37   arch-meson devhelp build "${meson_options[@]}"
38   meson compile -C build
41 check() {
42   meson test -C build --print-errorlogs
45 package_devhelp() {
46   groups=(gnome-extra)
48   meson install -C build --destdir "$pkgdir"
50   # Split -docs
51   mkdir -p docs/usr/share
52   mv -t docs/usr/share "$pkgdir"/usr/share/doc
55 package_devhelp-docs() {
56   pkgdesc+=" (documentation)"
57   depends=()
59   mv -t "$pkgdir" docs/*
62 # vim:set sw=2 sts=-1 et: