upgpkg: ocaml-topkg 1.0.5-2
[arch-packages.git] / nuspell / trunk / PKGBUILD
blob7c6d6de05dcb9adf87a88b58255749cda8253e69
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Conributor: Mélanie Chauvel (ariasuni) <perso at hack-libre dot org>
4 pkgname=nuspell
5 pkgver=5.1.2
6 pkgrel=2
7 pkgdesc='Fast and safe spellchecking C++ library'
8 arch=('x86_64')
9 url='https://nuspell.github.io/'
10 license=('LGPL3')
11 depends=('icu')
12 makedepends=('cmake' 'pandoc')
13 checkdepends=('catch2')
14 source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/nuspell/nuspell/archive/v${pkgver}.tar.gz")
15 sha512sums=('138212ae5340836f0bc85d9d5327dc43ffdb1481ca72678b4619938b86c4c8e7c156eec1446f459636460a9015cd476031ad53d0979325e637ed97c19e2f87c8')
17 # 1st rebuild enchant
18 # 2nd rebuild epiphany against nuspell/enchant that checkdepens on both
20 prepare() {
21   mkdir build
24 build() {
25   cd build
26   cmake ../${pkgbase}-${pkgver} \
27     -DCMAKE_BUILD_TYPE=Release \
28     -DCMAKE_INSTALL_PREFIX=/usr \
29     -DCMAKE_INSTALL_LIBDIR=/usr/lib \
30     -DBUILD_SHARED_LIBS=ON
31   make
34 check() {
35   cd build
36   make test
39 package() {
40   cd build
41   make DESTDIR="$pkgdir" install