upgpkg: ocaml-topkg 1.0.5-2
[arch-packages.git] / simple-scan / trunk / PKGBUILD
blob86a701e8baded6afb18baf554fd8842452add872
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Thomas Dziedzic < gostrc at gmail >
3 # Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
4 # Contributor: Joeny Ang <ang(dot)joeny(at)gmail(dot)com>
6 pkgname=simple-scan
7 pkgver=44.0
8 pkgrel=1
9 pkgdesc="Simple scanning utility"
10 url="https://gitlab.gnome.org/GNOME/simple-scan"
11 arch=(x86_64)
12 license=(GPL3)
13 depends=(
14   colord-sane
15   dconf
16   gtk3
17   libgusb
18   libhandy
19   sane
21 makedepends=(
22   git
23   meson
24   vala
25   yelp-tools
27 groups=(gnome-extra)
28 _commit=85794e3a443f3817c60f4466ebcbc107d8a63a77  # tags/44.0^0
29 source=("git+https://gitlab.gnome.org/GNOME/simple-scan.git#commit=$_commit")
30 b2sums=('SKIP')
32 pkgver() {
33   cd $pkgname
34   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
37 prepare() {
38   cd $pkgname
41 build() {
42   arch-meson $pkgname build
43   meson compile -C build
46 check() {
47   meson test -C build --print-errorlogs
50 package() {
51   meson install -C build --destdir "$pkgdir"
54 # vim:set sw=2 sts=-1 et: