db-move: moved adwaita-icon-theme from [testing] to [extra] (any)
[arch-packages.git] / blinken / trunk / PKGBUILD
blob9e19faf8c2afa206db41114ce167caa9eae7794a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=blinken
6 pkgver=23.04.0
7 pkgrel=1
8 pkgdesc='Memory Enhancement Game'
9 url='https://apps.kde.org/blinken/'
10 arch=(x86_64)
11 license=(GPL LGPL FDL)
12 groups=(kde-applications kde-education)
13 depends=(kxmlgui phonon-qt5 hicolor-icon-theme)
14 makedepends=(extra-cmake-modules kdoctools)
15 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('5ddcd6f04997beb4cb1703e30b67da6f71682d2c54ae228a7a92e1c60ab4560f'
17             'SKIP')
18 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
19               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
20               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
22 build() {
23   cmake -B build -S $pkgname-$pkgver \
24     -DBUILD_TESTING=OFF
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build