db-move: moved adwaita-icon-theme from [testing] to [extra] (any)
[arch-packages.git] / geoclue / trunk / PKGBUILD
blob26bf94615af98f77a6de643afb8c094484bc1c4f
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: György Balló <ballogy@freestart.hu>
4 pkgname=geoclue
5 pkgver=2.7.0
6 pkgrel=1
7 pkgdesc="Modular geoinformation service built on the D-Bus messaging system"
8 url="https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   avahi
13   json-glib
14   libmm-glib
15   libsoup3
17 makedepends=(
18   git
19   gobject-introspection
20   gtk-doc
21   libnotify
22   meson
23   systemd
24   vala
26 optdepends=('libnotify: Demo Agent')
27 provides=("geoclue2=$pkgver-$pkgrel")
28 conflicts=(geoclue2)
29 replaces=(geoclue2)
30 backup=(etc/geoclue/geoclue.conf)
31 _commit=bbfb6289dedb88cb8155d9f6868787d5432e1f90  # tags/2.7.0^0
32 source=("git+https://gitlab.freedesktop.org/geoclue/geoclue.git#commit=$_commit")
33 b2sums=('SKIP')
35 # Mozilla API keys (see https://location.services.mozilla.com/api)
36 # Note: These are for Arch Linux use ONLY. For your own distribution, please
37 # get your own set of keys. Feel free to contact heftig@archlinux.org for
38 # more information.
39 _mozilla_api_key=e05d56db0a694edc8b5aaebda3f2db6a
41 pkgver() {
42   cd geoclue
43   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
46 prepare() {
47   cd geoclue
50 build() {
51   local meson_options=(
52     -D dbus-srv-user=geoclue
53     -D dbus-sys-dir=/usr/share/dbus-1/system.d
54     -D mozilla-api-key="$_mozilla_api_key"
55   )
57   arch-meson geoclue build "${meson_options[@]}"
58   meson compile -C build
61 check() {
62   meson test -C build --print-errorlogs
65 package() {
66   meson install -C build --destdir "$pkgdir"
68   echo 'u geoclue - "Geoinformation service" /var/lib/geoclue' |
69     install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/geoclue.conf"
71   echo 'd /var/lib/geoclue 0755 geoclue geoclue' |
72     install -Dm644 /dev/stdin "$pkgdir/usr/lib/tmpfiles.d/geoclue.conf"
74   # Fixup mode to match polkit
75   install -d -o root -g 102 -m 750 "$pkgdir/usr/share/polkit-1/rules.d"
78 # vim:set sw=2 sts=-1 et: