db-move: moved adwaita-icon-theme from [testing] to [extra] (any)
[arch-packages.git] / gnome-tetravex / trunk / PKGBUILD
blobbd495b4e92bf151212d29db897c15458c23589f9
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-tetravex
5 pkgver=3.38.2
6 pkgrel=1
7 pkgdesc="Complete the puzzle by matching numbered tiles"
8 url="https://wiki.gnome.org/Apps/Tetravex"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3)
12 makedepends=(meson gobject-introspection vala yelp-tools appstream-glib git)
13 groups=(gnome-extra)
14 _commit=76c564d4cd5aaaf3e2eea89d538358070b019753  # tags/3.38.2^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-tetravex.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build -D build_cli=true
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   DESTDIR="$pkgdir" meson install -C build