archrelease: copy trunk to extra-x86_64
[arch-packages.git] / ecl / trunk / PKGBUILD
blob7aca24f679ab1733a0169a344f41657350da99ae
1 # Contributor: John Proctor <jproctor@prium.net>
2 # Maintainer: juergen <juergen@archlinux.org>
4 pkgname=ecl
5 pkgver=21.2.1
6 # Remember to rebuild sagemath when the soname changes
7 pkgrel=2
8 pkgdesc="Embeddable Common Lisp"
9 arch=('x86_64')
10 url="https://common-lisp.net/project/ecl/"
11 license=('LGPL')
12 depends=('bash' 'gmp')
13 makedepends=('texinfo')
14 provides=('common-lisp' 'cl-asdf')
15 options=('!makeflags')
16 source=("https://common-lisp.net/project/ecl/static/files/release/${pkgname}-${pkgver}.tgz")
17 sha256sums=('b15a75dcf84b8f62e68720ccab1393f9611c078fcd3afdd639a1086cad010900')
19 build() {
20   cd $pkgname-$pkgver
21   sed -i 's|-Wl,--rpath,~A|-Wl,--rpath,/usr/lib/ecl|' src/configure
22   CFLAGS+=" -fcommon"
23   ./configure \
24     --build=$CHOST \
25     --prefix=/usr \
26     --with-tcp \
27     --with-serve-event \
28     --with-clos-streams \
29     --with-system-gmp \
30     --without-x \
31     --without-clx \
32     --enable-threads \
33     --enable-shared \
34     --enable-boehm=included \
36   make
39 package() {
40   make -C $pkgname-$pkgver DESTDIR="$pkgdir" install