archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gst-python / repos / extra-x86_64 / PKGBUILD
blob9d73147fe70c70c84f439f6c94341648f06baf07
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 # Contributor: Jan de Groot <jgc@archlinux.org>
5 pkgname=gst-python
6 pkgver=1.18.5
7 pkgrel=1
8 pkgdesc="Multimedia graph framework - python bindings"
9 url="https://gstreamer.freedesktop.org/"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(python-gobject gst-plugins-base-libs)
13 makedepends=(git meson)
14 _commit=3d75c6b1eefc1a4190f58ac8d4610535f1acca3f  # tags/1.18.5^0
15 source=("git+https://gitlab.freedesktop.org/gstreamer/gst-python.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"
39   export PYTHONHASHSEED=0
40   python -m compileall -d /usr/lib "$pkgdir/usr/lib"
41   python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"