1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 # Contributor: Jan de Groot <jgc@archlinux.org>
8 pkgdesc="Multimedia graph framework - python bindings"
9 url="https://gstreamer.freedesktop.org/"
12 depends=(python-gobject gst-plugins-base-libs)
13 makedepends=(git meson)
14 _commit=3d75c6b1eefc1a4190f58ac8d4610535f1acca3f # tags/1.18.5^0
15 source=("git+https://gitlab.freedesktop.org/gstreamer/gst-python.git#commit=$_commit"
16 0001-python-Avoid-treating-float-as-int.patch)
18 '62f301faddb4c713bd21b2da95daec9b73b903da168d7c9649550a0678a1ff77')
22 git describe --tags | sed 's/-/+/g'
27 patch -Np3 -i ../0001-python-Avoid-treating-float-as-int.patch
31 arch-meson $pkgname build
32 meson compile -C build
36 meson test -C build --print-errorlogs
40 meson install -C build --destdir "$pkgdir"
41 python -m compileall -d /usr/lib "$pkgdir/usr/lib"
42 python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"