archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libgudev / trunk / PKGBUILD
blobde6cfeb0c19b6c0b090def1fff0048710118e6ed
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
3 pkgname=libgudev
4 pkgver=237
5 pkgrel=1
6 pkgdesc="GObject bindings for libudev"
7 url="https://wiki.gnome.org/Projects/libgudev"
8 arch=(x86_64)
9 license=(LGPL2.1)
10 depends=(systemd glib2)
11 makedepends=(gobject-introspection gtk-doc git meson umockdev vala)
12 _commit=dff7a794e55d6ad7a10e8edacd73aa047593e74c  # tags/237^0
13 source=("git+https://gitlab.gnome.org/GNOME/libgudev.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/-/+/g'
21 prepare() {
22   cd $pkgname
24   # Use a locale with "," decimal separator that we
25   # actually have available in the build environments
26   sed -e 's/fr_FR\.UTF-8/de_DE.UTF-8/g' \
27       -i tests/meson.build tests/test-double.c
30 build() {
31   arch-meson $pkgname build -D gtk_doc=true
32   meson compile -C build
35 check() {
36   meson test -C build --print-errorlogs
39 package() {
40   depends+=(libg{lib,object}-2.0.so libudev.so)
41   provides+=(libgudev-1.0.so)
43   meson install -C build --destdir "$pkgdir"
46 # vim:set ts=2 sw=2 et: