archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libimobiledevice / trunk / PKGBUILD
bloba7f65ca913b44b9539263f0930a8e84e16e505a8
1 # Contributor: Tom Gundersen <teg@jklm.no>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Gabriel Martinez < reitaka at gmail dot com >
5 pkgname=libimobiledevice
6 pkgver=1.3.0
7 pkgrel=5
8 pkgdesc="Library that talks the protocols to support iPhone and iPod Touch devices on Linux"
9 url="https://libimobiledevice.org/"
10 arch=('x86_64')
11 license=('GPL2' 'LGPL2.1')
12 depends=('libusbmuxd' 'usbmuxd' 'gnutls')
13 makedepends=('python' 'cython' 'libplist' 'autoconf-archive'
14              'git' 'python-setuptools')
15 _commit=15f8652126664e3a4b980e5d1c039b9053ce8566
16 source=("git+https://github.com/libimobiledevice/libimobiledevice#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/-/+/g'
24 prepare() {
25   cd $pkgname
26   # Update ac_python_devel.m4 to newer ax_python_devel.m4
27   git cherry-pick -n eea4f1be91
28   NOCONFIGURE=1 ./autogen.sh
31 build() (
32   cd $pkgname
33   ./configure --prefix=/usr --disable-openssl
34   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
35   make
38 check() {
39   cd $pkgname
40   make check
43 package() {
44   cd $pkgname
45   DESTDIR="$pkgdir" make install
48 # vim:set sw=2 et: