1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Sébastien Luttringer
3 # Contributor: Lawrence Lee <valheru@facticius.net>
4 # Contributor: Phillip Marvin <phillip.marvin@gmail.com>
5 # Contributor: keystone <phillip.marvin@gmail.com>
10 pkgdesc='Portable and efficient C programming interface (API) to determine the call-chain of a program'
12 url='https://www.nongnu.org/libunwind/'
15 makedepends=('texlive-core')
16 source=("https://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig})
17 sha512sums=('1df20ca7a8cee2f2e61294fa9b677e88fec52e9d5a329f88d05c2671c69fa462f6c18808c97ca9ff664ef57292537a844f00b18d142b1938c9da701ca95a4bab'
19 validpgpkeys=('5C96BDEAF5F47FB02BD4F6B965D98560914F3F48' # Arun Sharma
20 '1675C8DA2EF907FB116EB709EC52B396E6874AF2' # Dave Watson
21 '75D2CFC56CC2E935A4143297015A268A17D55FA4') # Dave Watson
25 ./configure --prefix=/usr
26 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
32 # This function is ``supposed'' to fail. Upstream know, but haven't fixed it.
38 make DESTDIR="$pkgdir" install
41 # vim:set ts=2 sw=2 et: