archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-imageformats / trunk / PKGBUILD
blob1350fe1b2755e15beaf05696245564fa2017a774
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-imageformats
6 _qtver=6.2.2
7 pkgver=${_qtver/-/}
8 pkgrel=1
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='Plugins for additional image formats: TIFF, MNG, TGA, WBMP'
13 depends=(qt6-base jasper libwebp libmng)
14 makedepends=(cmake ninja)
15 groups=(qt6)
16 _pkgfn="${pkgname/6-/}-everywhere-src-$_qtver"
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('214f6d552391a70d72ff534295ef06c59dba756b6323762967820963a15bd267')
20 build() {
21   cmake -B build -S $_pkgfn -G Ninja
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build
28   install -d "$pkgdir"/usr/share/licenses
29   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname