archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-websockets / trunk / PKGBUILD
blobbc7ca6b61b184850db3b5a550d580f881bc4a1a1
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-websockets
5 _qtver=6.2.2
6 pkgver=${_qtver/-/}
7 pkgrel=1
8 arch=(x86_64)
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Provides WebSocket communication compliant with RFC 6455'
12 depends=(qt6-base)
13 makedepends=(cmake ninja qt6-declarative)
14 optdepends=('qt6-declarative: QML bindings')
15 groups=(qt6)
16 _pkgfn="${pkgname/6-/}-everywhere-src-$_qtver"
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('8847a8bf0da6741b0bb22883c760037488c2d336fccc8cdb0b4e368f034c2076')
20 build() {
21   cmake -B build -S $_pkgfn -G Ninja
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build
28   install -d "$pkgdir"/usr/share/licenses
29   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname