archrelease: copy trunk to extra-x86_64
[arch-packages.git] / recode / repos / extra-x86_64 / PKGBUILD
blob17b286561894ccac73fc6be27760f8925b9b4ad1
1 # Maintainer: Kevin Piche <kevin@archlinux.org>
2 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
4 pkgname=recode
5 pkgver=3.7.9
6 pkgrel=1
7 pkgdesc="Converts files between various character sets and usages"
8 arch=('x86_64')
9 url='https://github.com/rrthomas/recode'
10 license=('GPL3' 'LGPL3')
11 depends=('glibc')
12 makedepends=('python')
13 source=("https://github.com/rrthomas/recode/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
14 sha256sums=('e4320a6b0f5cd837cdb454fb5854018ddfa970911608e1f01cc2c65f633672c4')
16 build() {
17   cd "${srcdir}/${pkgname}-${pkgver}"
19   ./configure \
20     --prefix=/usr \
21     --mandir=/usr/share/man \
22     --infodir=/usr/share/info \
23     --without-included-gettext
24   make
27 package() {
28   cd "${srcdir}/${pkgname}-${pkgver}"
30   make DESTDIR="${pkgdir}" install