archrelease: copy trunk to extra-x86_64
[arch-packages.git] / yelp / trunk / PKGBUILD
blob4c4d5e07409a20d7fac7bb28a279e795eb0481df
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=yelp
5 pkgver=41.2
6 pkgrel=1
7 pkgdesc="Get help with GNOME"
8 url="https://wiki.gnome.org/Apps/Yelp"
9 license=(GPL)
10 arch=(x86_64)
11 depends=(webkit2gtk-4.1 yelp-xsl libxslt xz bzip2)
12 makedepends=(gtk-doc itstool autoconf-archive git appstream-glib)
13 groups=(gnome)
14 _commit=72d73437a3d444739d722e580153f2dd8ee50f1d  # tags/41.2^0
15 source=("git+https://gitlab.gnome.org/GNOME/yelp.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
25   NOCONFIGURE=1 ./autogen.sh
28 build() {
29   cd $pkgname
30   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
31     --disable-static --enable-gtk-doc --enable-compile-warnings=minimum
32   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
33   make
36 package() {
37   cd $pkgname
38   make DESTDIR="$pkgdir" install