1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 # Contributor: Alexander Fehr <pizzapunk gmail com>
5 pkgname=desktop-file-utils
8 pkgdesc="Command line utilities for working with desktop entries"
10 url="https://www.freedesktop.org/wiki/Software/desktop-file-utils"
13 makedepends=(git meson)
14 _commit=54cec012921e52eb66b6ee1a1f40f2e9c9849f7c # tags/0.26
15 source=("git+https://gitlab.freedesktop.org/xdg/desktop-file-utils.git#commit=$_commit"
16 update-desktop-database.hook)
18 '501f1eb35d9fbbd61666f40302b0ce63425299edf023c075986a24dc3ef18575')
19 validpgpkeys=('C01EDE5BB0D91E26D003662EC76BB9FEEAD12EA7') # Hans Petter Jansson <hpj@cl.no>
23 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
29 # Support Desktop Entry Spec 1.5
30 git cherry-pick -n 425177a28b62 56d220dd679c
34 arch-meson $pkgname build
35 meson compile -C build
39 meson test -C build --print-errorlogs
43 depends+=(libglib-2.0.so)
45 meson install -C build --destdir "$pkgdir"
46 install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook