OCaml 4.14.0 rebuild: ocaml-ctypes 0.20.1-1
[arch-packages.git] / gnome-maps / trunk / PKGBUILD
blob583dd435d31a3f4996ef8f23e51fc2c91ec6970c
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-maps
5 pkgver=42.3
6 pkgrel=1
7 pkgdesc="A simple GNOME 3 maps application"
8 url="https://wiki.gnome.org/Apps/Maps"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(geocode-glib geoclue gjs libchamplain libgee folks gfbgraph libhandy
12          libgweather-4)
13 makedepends=(gobject-introspection git meson yelp-tools)
14 groups=(gnome)
15 options=(debug)
16 _commit=5b7a6cb36232c995ac5f7106731dc619423efaa8  # tags/v42.3^0
17 source=("git+https://gitlab.gnome.org/GNOME/gnome-maps.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname
29 build() {
30   arch-meson $pkgname build
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"