OCaml 4.14.0 rebuild: ocaml-ctypes 0.20.1-1
[arch-packages.git] / python-chardet / trunk / PKGBUILD
blob7686a8b969087602191cd695bac95818742d6b77
1 # Maintainer : Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: William Rea <sillywilly@gmail.com>
5 pkgname=python-chardet
6 pkgver=5.0.0
7 pkgrel=1
8 arch=('any')
9 url="https://github.com/chardet/chardet"
10 license=('LGPL')
11 depends=('python')
12 pkgdesc="Python3 module for character encoding auto-detection"
13 makedepends=('python-setuptools')
14 checkdepends=('python-pytest')
15 source=("https://pypi.io/packages/source/c/chardet/chardet-${pkgver}.tar.gz")
16 sha512sums=('3853248584d53d977abe0e6ab856e1526fd7360d9b94b4f08d03895da80ba9efac8882dbd3f919f0d52b0699c0d7fd68edb223c37512685976c6f2b212fbe0ff')
18 build() {
19    cd "$srcdir"/chardet-$pkgver
20    python setup.py build
23 check() {
24    cd "$srcdir"/chardet-$pkgver
25    python -m pytest
28 package() {
29    cd chardet-$pkgver
30    python setup.py install --root="$pkgdir" --optimize=1