OCaml 4.14.0 rebuild: ocaml-ctypes 0.20.1-1
[arch-packages.git] / python-fastimport / trunk / PKGBUILD
blobb280242273183fd212d00077a5bf5ddaea8b166f
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Martin Wimpress <code@flexion.org>
4 pkgname=python-fastimport
5 pkgver=0.9.14
6 pkgrel=3
7 pkgdesc='VCS fastimport/fastexport parser'
8 arch=(any)
9 url=https://github.com/jelmer/python-fastimport
10 license=(GPL2)
11 depends=(python)
12 makedepends=(
13   git
14   python-setuptools
16 _tag=6ed4b196e21974c6bac4323522cd086794618068
17 source=(git+https://github.com/jelmer/python-fastimport.git#tag=${_tag})
18 validpgpkeys=(DC837EE14A7E37347E87061700806F2BD729A457) # Jelmer Vernooij <jelmer@jelmer.uk>
19 sha256sums=(SKIP)
21 pkgver() {
22   cd python-fastimport
23   git describe --tags | sed 's/fastimport-//'
26 build() {
27   cd python-fastimport
28   python setup.py build
31 package() {
32   cd python-fastimport
33   python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
36 # vim: ts=2 sw=2 et: