1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
7 pkgdesc="The Apache Portable Runtime"
9 url="https://apr.apache.org/"
10 depends=('apr' 'expat' 'libxcrypt')
11 makedepends=('gdbm' 'libldap' 'unixodbc' 'openssl' 'nss' 'sqlite' 'mariadb-libs' 'db' 'postgresql-libs' 'python')
13 'gdbm: enable gdbm support'
14 'libldap: enable ldap support'
15 'unixodbc: enable odbc support'
16 'mariadb-libs: enable mysql/mariadb support'
17 'postgresql-libs: enable postgres support'
18 'db: enable berkley db support'
19 'sqlite: enable sqlite support'
20 'nss: enable nss crypto support'
21 'openssl: enable openssl crypto support'
24 source=(https://www.apache.org/dist/apr/apr-util-${pkgver}.tar.bz2{,.asc}
25 disable_failing_test.patch # TODO: figure out why dbm test fails
26 buildconf_config.guess_sub_location.patch)
27 sha512sums=('40eff8a37c0634f7fdddd6ca5e596b38de15fd10767a34c30bbe49c632816e8f3e1e230678034f578dd5816a94f246fb5dfdf48d644829af13bf28de3225205d'
29 'f3de06f845972e5fc85c0d01847bcd0cfbbdd5015798970c73e5ef1b2699c54118f00ba5b939d84bbdf748bd1a5088c1393289b1e62c005fa77878436c165802'
30 'd19024b8a19e46e85dd03e2c06afae13b527e56c0e2864e5b92652c8ed558f155647f50b9cfaddb6e919b5a60922970b1d9f6c7fc62cd5872b3d22e787f99c65')
31 validpgpkeys=('5B5181C2C0AB13E59DA3F7A3EC582EB639FF092C' # Jeff Trawick
32 'B1B96F45DFBDCCF974019235193F180AB55D9977' # William A. Rowe, Jr. <wrowe@rowe-clan.net>
33 '3CE3BAC2EB7BBC624D1D22D8F3B9D88CB87F79A9') # Nick Kew <niq@apache.org>
37 patch -Np1 -i ../buildconf_config.guess_sub_location.patch
38 patch -Np1 -i ../disable_failing_test.patch
39 ./buildconf --with-apr=`apr-1-config --srcdir`
43 cd "${srcdir}/apr-util-${pkgver}"
44 ./configure --prefix=/usr --with-apr=/usr --with-ldap --with-crypto \
45 --with-gdbm=/usr --with-sqlite3=/usr --with-nss=/usr --with-odbc=/usr \
46 --with-berkeley-db=/usr --with-pgsql=/usr --with-mysql=/usr --with-oracle=/usr \
52 cd "${srcdir}/apr-util-${pkgver}"
57 cd "${srcdir}/apr-util-${pkgver}"
58 make DESTDIR="${pkgdir}" install