1 # Maintainer: Sébastien Luttringer
6 pkgdesc='Administration tool for IP sets'
8 url='https://netfilter.org/projects/ipset/'
11 depends=('glibc' 'libmnl')
12 backup=("etc/$pkgname.conf")
13 source=("git://git.netfilter.org/ipset.git#tag=v$pkgver"
16 '5a0e326a80fd5ab2d9545faa1189b647cc866c9568ab6a9dd0833ba5863f39ce')
20 # apply patch from the source array (should be a pacman feature)
22 for filename in "${source[@]}"; do
23 if [[ "$filename" =~ \.patch$ ]]; then
24 echo "Applying patch ${filename##*/}"
25 patch -p1 -N -i "$srcdir/${filename##*/}"
34 ./configure --prefix=/usr --sbindir=/usr/bin --with-kmod=no
40 make DESTDIR="$pkgdir" install
42 install -dm755 "$pkgdir/usr/share/doc/$pkgname"
43 install -m644 README UPGRADE ChangeLog "$pkgdir/usr/share/doc/$pkgname"
44 # install pkgconfig file
45 install -Dm644 lib/libipset.pc "$pkgdir/usr/lib/pkgconfig/libipset.pc"
48 install -Dm 644 $pkgname.service \
49 "$pkgdir/usr/lib/systemd/system/$pkgname.service"
51 install -Dm 644 /dev/null "$pkgdir/etc/$pkgname.conf"
53 install -Dm 644 ipset/utils/ipset_bash_completion/ipset \
54 "$pkgdir/usr/share/bash-completion/completions/ipset"
57 # vim:set ts=2 sw=2 et: