archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libnotify / trunk / PKGBUILD
blobbe057225e4f264d53e6345985576c7bc0cbd19fa
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=libnotify
5 pkgver=0.7.11
6 pkgrel=1
7 pkgdesc="Library for sending desktop notifications"
8 url="https://gitlab.gnome.org/GNOME/libnotify"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(gdk-pixbuf2)
12 makedepends=(gtk3 gobject-introspection git meson docbook-xsl xmlto gtk-doc)
13 options=(debug)
14 _commit=e8a57f7245434603a0fda8b0b6a30017f08ce1e4  # tags/0.7.11^0
15 source=("git+$url.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   depends+=(libg{lib,object,io}-2.0.so libgdk_pixbuf-2.0.so)
38   provides+=(libnotify.so)
40   meson install -C build --destdir "$pkgdir"