1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
6 pkgname=('mtr' 'mtr-gtk')
9 pkgdesc='Combines the functionality of traceroute and ping into one tool'
10 url='https://www.bitwizard.nl/mtr/'
13 makedepends=('ncurses' 'gtk3' 'libcap' 'gdk-pixbuf2')
15 source=(https://github.com/traviscross/mtr/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
16 sha512sums=('a7d69e0c551a10ae80a650a34588119e6c6b124a8c2c93d3de29e5daa6ef99f9217d875529d443c3760cd6fd7bd04d1e9abe33ef12635826c66a98bd776c1690')
17 b2sums=('3c972675b97945b96562802c5d0f10de963160682c93c0ea2991b72eca33d136d18948c5e746ca3dfb280ebc9c3ab154e7774f8409ed4e5f7470a8feb128e71b')
20 (cd ${pkgbase}-${pkgver}
21 echo "${pkgver}" > .tarball-version
24 cp -ra ${pkgbase}-${pkgver}{,-cli}
28 (cd ${pkgbase}-${pkgver}-cli
35 (cd ${pkgbase}-${pkgver}
44 pkgdesc='Combines the functionality of traceroute and ping into one tool (CLI version)'
45 depends=('ncurses' 'libcap' libncursesw.so)
46 optdepends=('bash-completion: bash completion support')
47 cd ${pkgbase}-${pkgver}-cli
48 make DESTDIR="${pkgdir}" install
52 pkgdesc='Combines the functionality of traceroute and ping into one tool (GTK version)'
53 depends=('ncurses' 'libcap' 'gtk3' 'gdk-pixbuf2'
54 libgtk-3.so libgobject-2.0.so libgdk_pixbuf-2.0.so libgobject-2.0.so libglib-2.0.so libncursesw.so)
55 optdepends=('bash-completion: bash completion support')
57 provides=("mtr=${pkgver}")
58 cd ${pkgbase}-${pkgver}
59 make DESTDIR="${pkgdir}" install