1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-languageserver
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='An implementation of the Language Server Protocol'
13 makedepends=(cmake ninja)
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('70aad8f7060e1e0c40365cb3f0f5f572643a5390f59d8e5a327df6fc0a9eeeaa')
21 cmake -B build -S $_pkgfn -G Ninja
26 DESTDIR="$pkgdir" cmake --install build
28 install -d "$pkgdir"/usr/share/licenses
29 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname