archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-tools / trunk / PKGBUILD
blobbfca6c303d660a0341de798ee22b7541d4397d22
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-tools
6 _qtver=6.3.0
7 pkgver=${_qtver/-/}
8 pkgrel=1
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='A cross-platform application and UI framework (Development Tools, QtHelp)'
13 depends=(qt6-base)
14 makedepends=(cmake ninja qt6-declarative clang llvm)
15 optdepends=('qt6-declarative: for qdoc' 'clang: for qdoc and lupdate')
16 groups=(qt6)
17 options=(debug)
18 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
19 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
20 sha256sums=('fce94688ea925782a2879347584991f854630daadba6c52aed6d93e33cd0b19c')
22 build() {
23   cmake -B build -S $_pkgfn -G Ninja \
24     -DINSTALL_PUBLICBINDIR=usr/bin
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build
31 # Install symlinks for user-facing tools
32   cd "$pkgdir"
33   mkdir usr/bin
34   while read _line; do
35     ln -s $_line
36   done < "$srcdir"/build/user_facing_tool_links.txt
38   install -d "$pkgdir"/usr/share/licenses
39   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname