1 # Maintainer: Ronald van Haren <ronald.archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
7 pkgdesc='A collection of sparse matrix libraries'
8 url='http://faculty.cse.tamu.edu/davis/suitesparse.html'
10 depends=(metis lapack mpfr)
11 makedepends=(gcc-fortran cmake chrpath)
14 source=(https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v$pkgver/$pkgname-$pkgver.tar.gz
15 suitesparse-no-demo.patch)
16 sha256sums=('5fb0064a3398111976f30c5908a8c0b40df44c6dd8f0cc4bfa7b9e45d8c647de'
17 '409b32e546ec4936d0d88e39c59ee68dfd9f630d8c454ce1e3d58243df7ad396')
20 cd SuiteSparse-$pkgver
21 patch -p1 -i ../suitesparse-no-demo.patch # Don't run demo
25 cd SuiteSparse-$pkgver
27 BLAS=-lblas LAPACK=-llapack MY_METIS_LIB=/usr/lib/libmetis.so make
32 cd SuiteSparse-$pkgver
33 install -dm755 "${pkgdir}"/usr/{include,lib}
35 BLAS=-lblas LAPACK=-llapack MY_METIS_LIB=/usr/lib/libmetis.so \
36 make INSTALL_LIB="${pkgdir}"/usr/lib INSTALL_INCLUDE="${pkgdir}"/usr/include install
39 chrpath -d "$pkgdir"/usr/lib/*