archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xfce4-settings / trunk / PKGBUILD
blob14bf15b80aa1bc54e4f33c15d2ef766e7acb49fa
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: tobias <tobias funnychar archlinux.org>
3 # Contributor: Corrado Primier <bardo@aur.archlinux.org>
5 pkgname=xfce4-settings
6 pkgver=4.16.2
7 pkgrel=2
8 pkgdesc="Settings manager of the Xfce desktop"
9 arch=('x86_64')
10 url="https://docs.xfce.org/xfce/xfce4-settings/start"
11 license=('GPL2')
12 groups=('xfce4')
13 depends=('exo' 'garcon' 'libxfce4ui' 'xfconf' 'libnotify' 'libcanberra'
14          'colord' 'libxklavier' 'adwaita-icon-theme' 'gnome-themes-extra')
15 makedepends=('intltool' 'xf86-input-libinput')
16 optdepends=('python: xfce4-compose-mail -- "mailto:" URI handling')
17 source=(https://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
18         $pkgname-fix-ColorSettings-release.patch::https://gitlab.xfce.org/xfce/xfce4-settings/-/commit/4bc8ef847a1a.patch
19         default-xsettings-xml.patch)
20 sha256sums=('4dd7cb420860535e687f673c0b5c0274e0d2fb67181281d4b85be9197da03d7e'
21             '551add99a48c7c7863638967194c98e17a4e39bfc391da7b66094957d102dc57'
22             '8e9a6c70ab0ceb5d91b637dc290768f8a47edb5d7b6e2eebc4459dbc4ee040d7')
23 prepare() {
24   cd "$srcdir/$pkgname-$pkgver"
26   # https://gitlab.xfce.org/xfce/xfce4-settings/-/issues/211
27   patch -Np1 -i ../$pkgname-fix-ColorSettings-release.patch
29   # Enable Adwaita theme and font hinting by default
30   patch -Np1 -i "$srcdir/default-xsettings-xml.patch"
33 build() {
34   cd "$srcdir/$pkgname-$pkgver"
36   ./configure \
37     --prefix=/usr \
38     --sysconfdir=/etc \
39     --localstatedir=/var \
40     --disable-static \
41     --enable-xrandr \
42     --enable-xcursor \
43     --enable-libnotify \
44     --enable-libxklavier \
45     --enable-pluggable-dialogs \
46     --enable-sound-settings \
47     --disable-debug
48   make
51 package() {
52   cd "$srcdir/$pkgname-$pkgver"
53   make DESTDIR="$pkgdir" install
56 # vim:set ts=2 sw=2 et: