4.10.3-2: add gtktreeviewmodel fixes
[arch-packages.git] / dconf-editor / repos / extra-x86_64 / PKGBUILD
blob43ae5a8cba5d87b8b409fb7163a1f022d14e062e
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=dconf-editor
4 pkgver=43.0
5 pkgrel=1
6 pkgdesc="GSettings editor for GNOME"
7 url="https://wiki.gnome.org/Apps/DconfEditor"
8 arch=(x86_64)
9 license=(GPL3)
10 groups=(gnome-extra)
11 depends=(libhandy dconf)
12 makedepends=(vala meson git)
13 options=(debug)
14 _commit=27b4f9d1d53783507f03eb9b6a140f0646ce746e  # tags/43.0^0
15 source=("git+https://gitlab.gnome.org/GNOME/dconf-editor.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"
40 # vim:set sw=2 sts=-1 et: