4.10.3-2: add gtktreeviewmodel fixes
[arch-packages.git] / kcompletion / trunk / PKGBUILD
blob1f4e06fe06b5a3bc2badcf9b60d7b3054cc3d944
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kcompletion
6 pkgver=5.105.0
7 pkgrel=1
8 pkgdesc='Text completion helpers and widgets'
9 arch=(x86_64)
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(kwidgetsaddons kconfig)
13 makedepends=(extra-cmake-modules qt5-tools qt5-doc clang doxygen)
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('6e76e822a8b4e49d3357958fd3880858a59ccf4defd45a0e248c57535788b981'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
20 build() {
21   cmake -B build -S $pkgname-$pkgver \
22     -DBUILD_TESTING=OFF \
23     -DBUILD_QCH=ON
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build