4.10.3-2: add gtktreeviewmodel fixes
[arch-packages.git] / unison / trunk / PKGBUILD
blobb1750bb0c69cb86e7fe16772e7025df9da24557d
1 #Maintainer: Gaetan Bisson <bisson@archlinux.org>
2 #Contributor: Tobias Powalowski <tpowa@archlinux.org>
4 pkgname=unison
5 pkgver=2.53.3
6 pkgrel=1
7 pkgdesc='File-synchronization tool'
8 #url='https://github.com/bcpierce00/unison/'
9 url='https://www.cis.upenn.edu/~bcpierce/unison/'
10 arch=('x86_64')
11 license=('GPL2')
12 optdepends=('gtk3: graphical interface')
13 makedepends=('ocaml>=4.11.0' 'emacs' 'lablgtk3')
14 source=("https://github.com/bcpierce00/unison/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
15         'large.patch'
16         'desktop')
17 sha512sums=('f3fafd5e1a2950a00ed8bcc682036180ea40eff1ccfa1fc671cca49954890a535ee48faf1e8e62002563143e5479b9df1eca1db1caf03dffc50449fb467b8e2b'
18             'e2f7a5e6e832ee9c694f36e399178652456d2047b22cba86603982cd6f6caf54e520fc87a8bde1940b2da46102cf3aa89f3e062c965efc77cd840b47e01b4d2f'
19             '2043acd79dde45b9b724076e361f117a6b42ec0c0321a2d2836b55a7fe5b03c45d81200819f64bc3e7d446f979a5a4a66c3d8c3ac7bdf1fe469c480ae2ac9464')
20 options=('!makeflags')
22 prepare() {
23         cd ${pkgname}-${pkgver}
24         patch -p0 -i ../large.patch
27 build() {
28         cd ${pkgname}-${pkgver}
29         for ui in gtk3 text; do
30                 cp -a . build || true
31                 pushd build
32                 export CFLAGS=
33                 make all UISTYLE=$ui DEBUGGING=false THREADS=true
34                 mv src/unison src/unison-$ui
35                 mv src/unison-* ..
36                 popd
37                 rm -fr build
38         done
41 package() {
42         cd ${pkgname}-${pkgver}
43         install -d "${pkgdir}"/usr/bin
44         install -m755 unison-* "${pkgdir}"/usr/bin
45         ln -s unison-text "${pkgdir}"/usr/bin/unison
47         install -Dm644 ../desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
48         install -Dm644 icons/U.svg "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
49         for i in 16 24 32 48 256; do
50                 install -Dm644 icons/U.${i}x${i}x16m.png "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/${pkgname}.png"
51         done