archrelease: copy trunk to extra-x86_64
[arch-packages.git] / archinstall / trunk / PKGBUILD
blob64e4ecfdf736b8c6de14864ac9a5d21af9dccc76
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Maintainer: Giancarlo Razzolini <grazzolini@archlinux.org>
3 # Contributor: Anton Hvornum <anton@hvornum.se>
4 # Contributor: demostanis worlds <demostanis@protonmail.com>
6 pkgname=archinstall
7 pkgver=2.5.6
8 pkgrel=1
9 pkgdesc="Just another guided/automated Arch Linux installer with a twist"
10 arch=(any)
11 url="https://github.com/archlinux/archinstall"
12 license=(GPL3)
13 depends=(
14   python
15   systemd
17 makedepends=(
18   python-build
19   python-installer
20   python-setuptools
21   python-sphinx
22   python-wheel
24 optdepends=(
25   'python-systemd: for systemd-journald support'
27 provides=(python-archinstall)
28 source=(
29   $pkgname-v$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz
30   $pkgname-v$pkgver.tar.gz.sig::$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz.sig
32 sha512sums=('a5b500da0415504ad9ec5abf40ee479aaccf760ea1566f2511ed877856d163f006ef3ea7fd92733b5f52208d6f05083017bcbcc80c2907830d70471ebc2baea6'
33             'SKIP')
34 b2sums=('98fd6b0bd2a58211a539ca648cc15814a97b5b49bfe698d628c20057d7f5fd31ecb6684259962dc8483ce17800fa7b45f87424cd0d460b835903c1d237ff3766'
35         'SKIP')
36 validpgpkeys=('256F73CEEFC6705C6BBAB20E5FBBB32941E3740A') # Anton Hvornum (Torxed) <anton@hvornum.se>
38 prepare() {
39   cd $pkgname-$pkgver
40   # use real directories for examples and profiles, as symlinks do not work
41   # with flit or setuptools PEP517 backends
42   rm -fv $pkgname/{examples,profiles}
43   mv -v examples profiles $pkgname/
46 build() {
47   cd $pkgname-$pkgver
48   python -m build --wheel --no-isolation
49   PYTHONDONTWRITEBYTECODE=1 make man -C docs
52 package() {
53   cd $pkgname-$pkgver
54   python -m installer --destdir="$pkgdir" dist/*.whl
55   install -vDm 644 docs/_build/man/archinstall.1 -t "$pkgdir/usr/share/man/man1/"