archrelease: copy trunk to extra-x86_64
[arch-packages.git] / atk / trunk / PKGBUILD
blobab35be8fb52d5f142bd7264994c12350a5bc8e8b
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=atk
5 pkgver=2.38.0
6 pkgrel=1
7 pkgdesc="Interface definitions of accessibility infrastructure"
8 url="https://gitlab.gnome.org/GNOME/atk"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(glib2)
12 makedepends=(gobject-introspection git gtk-doc meson)
13 provides=(libatk-1.0.so)
14 _commit=f1051ba57a2110c46a136a48f4d60a405bc2c3f5  # tags/2.38.0^0
15 source=("git+https://gitlab.gnome.org/GNOME/atk.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd atk
20   git describe --tags | sed 's/^ATK_//;s/_/./g;s/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd atk
27 build() {
28   arch-meson atk build -D docs=true
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"