archrelease: copy trunk to extra-x86_64
[arch-packages.git] / brasero / trunk / PKGBUILD
blob6b838be48fd9d66eef2b6b9e5a6c40b0236a4c9e
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: Jan de Groot <jgc@archlinux.org>
4 # Contributor: William Rea <sillywilly@gmail.com>
6 pkgname=brasero
7 pkgver=3.12.3+r24+gd01ba738
8 pkgrel=1
9 pkgdesc="CD/DVD mastering tool"
10 url="https://wiki.gnome.org/Apps/Brasero"
11 arch=(x86_64)
12 license=(GPL)
13 depends=(gtk3 gst-plugins-good totem-plparser cdrtools cdrdao shared-mime-info
14          libcanberra dvd+rw-tools dconf libsm libnotify gvfs tracker3)
15 makedepends=(gtk-doc yelp-tools gnome-common intltool libburn libisofs
16              gobject-introspection itstool docbook-xsl git)
17 optdepends=('libburn: alternative back-end'
18             'libisofs: libburn back-end'
19             'dvdauthor: video project'
20             'vcdimager: video project')
21 _commit=d01ba738eb22502852fdc6001d2422bc7af04116  # master
22 source=("git+https://gitlab.gnome.org/GNOME/brasero.git#commit=$_commit")
23 sha256sums=('SKIP')
25 pkgver() {
26   cd brasero
27   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
30 prepare() {
31   cd brasero
32   NOCONFIGURE=1 ./autogen.sh
35 build() {
36   cd brasero
37   ./configure \
38     --prefix=/usr \
39     --sysconfdir=/etc \
40     --localstatedir=/var \
41     --disable-caches \
42     --disable-search \
43     --disable-schemas-compile \
44     --enable-compile-warnings=minimum \
45     --enable-gtk-doc
46   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
47   make
50 package() {
51   cd brasero
52   make DESTDIR="$pkgdir" install