1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Matt Harrison <matt@harrison.us.com>
3 # Contributor: Erik van der Kolk <developer at smerik dot nl>
6 pkgname=editorconfig-core-c
9 pkgdesc='EditorConfig core code written in C (for use by plugins supporting EditorConfig parsing)'
11 url='https://github.com/editorconfig/editorconfig-core-c'
14 makedepends=(cmake doxygen)
15 source=(https://github.com/editorconfig/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
16 sha256sums=('36052a5371731d915b53d9c7a24a11c4032585ccacb392ec9d58656eef4c0edf')
19 cmake -B build -S $pkgname-$pkgver \
20 -DCMAKE_INSTALL_PREFIX=/usr \
21 -DCMAKE_C_FLAGS="$CFLAGS -ffat-lto-objects"
26 DESTDIR="$pkgdir" cmake --install build
28 install -Dm644 $pkgname-$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname