archrelease: copy trunk to extra-x86_64
[arch-packages.git] / eog / trunk / PKGBUILD
blob2e89e40b75823b74fbf7512325d2721db492b7de
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgbase=eog
5 pkgname=(eog eog-docs)
6 pkgver=44.1
7 pkgrel=1
8 pkgdesc="Eye of Gnome: An image viewing and cataloging program"
9 url="https://wiki.gnome.org/Apps/EyeOfGnome"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(
13   exempi
14   gnome-desktop
15   lcms2
16   libexif
17   libhandy
18   libpeas
19   librsvg
20   webp-pixbuf-loader
22 makedepends=(
23   gi-docgen
24   git
25   gobject-introspection
26   meson
27   systemd
28   yelp-tools
30 _commit=d989d8ac5e60b8c9c429cbe67f3c79b26f22d75b  # tags/44.1^0
31 source=("git+https://gitlab.gnome.org/GNOME/eog.git#commit=$_commit")
32 b2sums=('SKIP')
34 pkgver() {
35   cd eog
36   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
39 build() {
40   local meson_options=(
41     -D gtk_doc=true
42     -D libportal=false
43   )
45   arch-meson eog build "${meson_options[@]}"
46   meson compile -C build
49 check() {
50   meson test -C build --print-errorlogs
53 package_eog() {
54   optdepends=('eog-plugins: Additional features')
55   groups=(gnome)
57   meson install -C build --destdir "$pkgdir"
59   mkdir -p doc/usr/share
60   mv {"$pkgdir",doc}/usr/share/gtk-doc
63 package_eog-docs() {
64   pkgdesc+=" (documentation)"
65   depends=()
67   mv doc/* "$pkgdir"
70 # vim:set sw=2 sts=-1 et: