archrelease: copy trunk to extra-x86_64
[arch-packages.git] / farstream-0.1 / trunk / PKGBUILD
blob3c7fb6bd7830e84e7a4757b3671d8b83e52ec4b4
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=farstream-0.1
5 _pkgname=farstream
6 pkgver=0.1.2
7 pkgrel=5
8 pkgdesc="Audio/Video Communications Framework (legacy version)"
9 arch=('x86_64')
10 url="http://www.freedesktop.org/wiki/Software/Farstream"
11 license=('LGPL2.1')
12 depends=('libnice' 'gstreamer0.10-base' 'gstreamer0.10-bad-plugins' 'gstreamer0.10-good-plugins' 'gstreamer0.10-ffmpeg')
13 makedepends=('gobject-introspection' 'gstreamer0.10-python' 'python2-gobject2' 'git' 'gtk-doc')
14 source=(git://git.collabora.co.uk/git/farstream.git#commit=54e28e95bed4f04bc95dae509c3724399c79fa29
15         farstream-0.1.2-prefer-vp8.patch
16         farstream-rtp-session.patch
17         codec-discovery-intersect.patch
18         intersect-instead-of-merge.patch
19         rtp-memleak.patch
20         fix-crash.patch)
21 sha256sums=('SKIP'
22             '5f8f2876bde0f21383b3d059c94914a2fcd63d45a1bb1b5cd2e2208cd2536da5'
23             '30e95a24800a26ff84e0cffeccb525e704fab6024402cd1d3e7fd957909650bf'
24             '385d7c72e269bf48bd41937442d819a1e6d0f2472b903670a8a5555f5cb96586'
25             'c3988f90fc50ee557399b240de78f3fb4fe191f339143f6943b963c2e0fddaf2'
26             'b966312ccad90dd30b78ee2df49e9637b3b573e498668bcc58ac208f254440db'
27             '8fde8f5fb16475aabeda2d6e48c86b105341fd72cde02cd6655ca7f41b4a98ed')
29 prepare() {
30   cd farstream
31   patch -Np1 -i ../farstream-0.1.2-prefer-vp8.patch
32   patch -Np1 -i ../farstream-rtp-session.patch
33   patch -Np1 -i ../intersect-instead-of-merge.patch
34   patch -Np1 -i ../codec-discovery-intersect.patch
35   patch -Np1 -i ../rtp-memleak.patch
36   patch -Np1 -i ../fix-crash.patch
37   sed -i -e 's/AC_INIT(Farstream, 0.1.2.1/AC_INIT(Farstream, 0.1.2/' configure.ac
40 check() {
41   cd farstream
42   # MSN test fails because of missing libmimic + mimenc element
43   make check || return 0
45 build() {
46   cd farstream
47   NOCONFIGURE=1 ./autogen.sh
48   ./configure \
49     --prefix=/usr \
50     --with-package-name='Arch Linux Farstream 0.1 Package' \
51     --with-package-origin='https://www.archlinux.org/' \
52     --disable-gtk-doc --disable-static
53   make -j1
56 package() {
57   cd farstream
58   make DESTDIR="$pkgdir" install
61 # vim:set ts=2 sw=2 et: