archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gawk / repos / testing-x86_64 / PKGBUILD
blobbd029a6183dce3eaf03353cd84f6b8d80da46cf4
1 # Maintainer:
2 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
4 pkgname=gawk
5 pkgver=5.2.2
6 pkgrel=1
7 pkgdesc="GNU version of awk"
8 arch=('x86_64')
9 url="https://www.gnu.org/software/gawk/"
10 license=('GPL')
11 depends=('sh' 'glibc' 'mpfr')
12 provides=('awk')
13 source=(https://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.sig})
14 validpgpkeys=('D1967C63788713177D861ED7DF597815937EC0D2') # Arnold Robbins
15 sha256sums=('945aef7ccff101f20b22a10802bc005e994ab2b8ea3e724cc1a197c62f41f650'
16             'SKIP')
18 build() {
19   cd ${pkgname}-${pkgver}
20   ./configure --prefix=/usr --libexecdir=/usr/lib --sysconfdir=/etc --without-libsigsegv
21   make
24 check() {
25   cd ${pkgname}-${pkgver}
26   make check
29 package() {
30   cd ${pkgname}-${pkgver}
31   make DESTDIR="${pkgdir}" install