1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-control-center
7 pkgdesc="GNOME's main interface to configure various aspects of the desktop"
8 url="https://gitlab.gnome.org/GNOME/gnome-control-center"
23 gsettings-desktop-schemas
36 sound-theme-freedesktop
53 'fwupd: device security panel'
54 'gnome-remote-desktop: screen sharing'
55 'gnome-user-share: WebDAV file sharing'
56 'malcontent: application permission control'
57 'networkmanager: network settings'
58 'openssh: remote login'
59 'power-profiles-daemon: power profiles'
60 'rygel: media sharing'
61 'system-config-printer: printer settings'
64 _commit=da661203820d5766ff10fd7f64d2117470c70a2a # tags/44.1^0
66 "git+https://gitlab.gnome.org/GNOME/gnome-control-center.git#commit=$_commit"
67 "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
72 '8695bc08c06026b7bfdd43941b4e07bb3ffbaa4e709be0b23ee138d24b6dbc8f')
76 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
82 # Install bare logos into pixmaps, not icons
83 git apply -3 ../pixmaps-dir.diff
85 git submodule init subprojects/gvc
86 git submodule set-url subprojects/gvc "$srcdir/libgnome-volume-control"
87 git -c protocol.file.allow=always submodule update
97 arch-meson $pkgname build "${meson_options[@]}"
98 meson compile -C build
102 GTK_A11Y=none meson test -C build --print-errorlogs
106 meson install -C build --destdir "$pkgdir"
107 install -d -o root -g 102 -m 750 "$pkgdir/usr/share/polkit-1/rules.d"
110 # vim:set sw=2 sts=-1 et: