archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-user-share / trunk / PKGBUILD
blobbb5cc21e765782ff8cd414ab2bc72a827bb28409
1 # Contributor: Roman Kyrylych <roman@archlinux.org>
3 pkgname=gnome-user-share
4 pkgver=43.0
5 pkgrel=1
6 pkgdesc="Easy to use user-level file sharing for GNOME"
7 url="https://gitlab.gnome.org/GNOME/gnome-user-share"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(glib2 dconf mod_dnssd systemd)
11 makedepends=(git meson)
12 groups=(gnome)
13 _commit=a0e790aa9494db9d1b1f48b4fc0d2f78e112044d  # tags/43.0^0
14 source=("git+https://gitlab.gnome.org/GNOME/gnome-user-share.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   local meson_options=(
28     -D httpd=/usr/bin/httpd
29     -D modules_path=/usr/lib/httpd/modules
30   )
32   arch-meson $pkgname build "${meson_options[@]}"
33   meson compile -C build
36 check() {
37   meson test -C build --print-errorlogs
40 package() {
41   meson install -C build --destdir "$pkgdir"
44 # vim:set sw=2 sts=-1 et: