1 # Contributor: Roman Kyrylych <roman@archlinux.org>
3 pkgname=gnome-user-share
6 pkgdesc="Easy to use user-level file sharing for GNOME"
7 url="https://gitlab.gnome.org/GNOME/gnome-user-share"
10 depends=(glib2 dconf mod_dnssd systemd)
11 makedepends=(git meson)
13 _commit=a0e790aa9494db9d1b1f48b4fc0d2f78e112044d # tags/43.0^0
14 source=("git+https://gitlab.gnome.org/GNOME/gnome-user-share.git#commit=$_commit")
19 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
28 -D httpd=/usr/bin/httpd
29 -D modules_path=/usr/lib/httpd/modules
32 arch-meson $pkgname build "${meson_options[@]}"
33 meson compile -C build
37 meson test -C build --print-errorlogs
41 meson install -C build --destdir "$pkgdir"
44 # vim:set sw=2 sts=-1 et: