1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Balló György <ballogyor+arch at gmail dot com>
3 # Contributor: Ionut Biru <ibiru@archlinux.org>
6 pkgname=(gtksourceview5 gtksourceview5-docs)
9 pkgdesc="A text widget adding syntax highlighting and more to GNOME"
10 url="https://wiki.gnome.org/Projects/GtkSourceView"
25 checkdepends=(xorg-server-xvfb)
26 _commit=21ca89f7947d232f1ebd12b2a7780994d7771ea4 # tags/5.8.0^0
27 source=("git+https://gitlab.gnome.org/GNOME/gtksourceview.git#commit=$_commit")
32 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
40 arch-meson gtksourceview build -D gtk_doc=true
41 meson compile -C build
45 GTK_A11Y=none dbus-run-session xvfb-run -s '-nolisten local' \
46 meson test -C build --print-errorlogs
49 package_gtksourceview5() {
50 provides=(libgtksourceview-${pkgver%%.*}.so)
52 meson install -C build --destdir "$pkgdir"
54 mkdir -p doc/usr/share
55 mv {"$pkgdir",doc}/usr/share/doc
58 package_gtksourceview5-docs() {
59 pkgdesc+=" (documentation)"
65 # vim:set sw=2 sts=-1 et: