archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gtksourceview5 / trunk / PKGBUILD
blob84489cec874c32b7859e0985959a2cc78537fb01
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Balló György <ballogyor+arch at gmail dot com>
3 # Contributor: Ionut Biru <ibiru@archlinux.org>
5 pkgbase=gtksourceview5
6 pkgname=(gtksourceview5 gtksourceview5-docs)
7 pkgver=5.8.0
8 pkgrel=1
9 pkgdesc="A text widget adding syntax highlighting and more to GNOME"
10 url="https://wiki.gnome.org/Projects/GtkSourceView"
11 arch=(x86_64)
12 license=(LGPL)
13 depends=(
14   gtk4
15   libxml2
16   pcre2
18 makedepends=(
19   gi-docgen
20   git
21   gobject-introspection
22   meson
23   vala
25 checkdepends=(xorg-server-xvfb)
26 _commit=21ca89f7947d232f1ebd12b2a7780994d7771ea4  # tags/5.8.0^0
27 source=("git+https://gitlab.gnome.org/GNOME/gtksourceview.git#commit=$_commit")
28 b2sums=('SKIP')
30 pkgver() {
31   cd gtksourceview
32   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
35 prepare() {
36   cd gtksourceview
39 build() {
40   arch-meson gtksourceview build -D gtk_doc=true
41   meson compile -C build
44 check() {
45   GTK_A11Y=none dbus-run-session xvfb-run -s '-nolisten local' \
46     meson test -C build --print-errorlogs
49 package_gtksourceview5() {
50   provides=(libgtksourceview-${pkgver%%.*}.so)
52   meson install -C build --destdir "$pkgdir"
54   mkdir -p doc/usr/share
55   mv {"$pkgdir",doc}/usr/share/doc
58 package_gtksourceview5-docs() {
59   pkgdesc+=" (documentation)"
60   depends=()
62   mv doc/* "$pkgdir"
65 # vim:set sw=2 sts=-1 et: